Windows 11 - Network - Some computers on network not consistently appearing in File Explorer / Network app


swbrains

Active member
Local time
9:35 PM
Posts
19
Location
Florida, USA
OS
Windows 11
I have been plagued by this issue for years. I have a couple of Windows desktop PCs and a couple of laptops on our home network. I often want to make a file accessible to all of them so I put it in my \Users\Public folder so the other computers can grab it, but then I go to those PCs and they don't see my desktop PC at all in their Network app (or vice versa). Sometimes I can manually enter \\COMPUTERNAME in File Explorer and access another PC on the network directly, sometimes that fails too. It has always been extremely frustrating.

I had already gone into Windows Advanced Sharing settings on all PCs and made the following changes:

1) enabled network discovery under Private Network
2) enabled file and printer sharing under Private Network
3) enabled "set up network connected devices automatically" in Private Network
4) enabled public folder sharing under All Networks

But still I would have trouble consistently seeing all PCs in the Network app or File Manager when they were active (i.e. not sleeping). Perhaps it was due to those PCs being asleep earlier and then somehow not "reconnecting" to the network properly after waking, but I really didn't know. It just happened a lot and was very annoying.

Today I learned that resetting the "Function Discovery Resource Publication" service would resolve that issue, but I couldn't seem to set up a trigger in Task Scheduler that would restart it upon booting and after waking from sleep. After much additional searching, I ran across a post in the Microsoft forums that (I think) has finally resolved this issue for good (well, seemingly at least for now to my satisfaction):


In case that article ever goes away, it basically says that you can add "LanmanWorkstation" as an additional startup dependency for the "Function Discovery Resource Publication" (FDResPub) service, which seems to do the trick. To do this, you simply open an elevated command prompt (i.e. use the "run as administrator" right-click context menu option to start cmd.exe), then execute the following command:

sc config fdrespub depend= RpcSs/http/fdphost/LanmanWorkstation

Reboot each device after executing this command, and the devices should see each other more reliably in Network and File Manager. I tested sleeping and waking several of the PCs and watched them disappear and reappear automatically from my desktop's Network app as I did so. :-)

I am adding this here in case anyone else is on the hunt for a solution to Windows computers not appearing consistently visible to other devices on their network as yet another solution to try. I hope it makes someone else as happy as it made me today!
 
Windows Build/Version
Windows 11

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    MinisForum NAB6
    CPU
    Intel Core i7-12650H
    Memory
    64 GB
Thank you for posting that. If this works, you will indeed help a lot of folks who have the exact same problem. This issue has plagued users for years.
Mark this thread as solved so it flags people that this is a solution, not a problem.
 

My Computers

System One System Two

  • OS
    Windows 11 Pro 23H2 22631.3737
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 7080
    CPU
    i9-10900 10 core 20 threads
    Motherboard
    DELL 0J37VM
    Memory
    32 gb
    Graphics Card(s)
    none-Intel UHD Graphics 630
    Sound Card
    Integrated Realtek
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    1tb Solidigm m.2 nvme+256gb SKHynix m.2 nvme /External +512gb Samsung m.2 sata+1tb Kingston m2.nvme
    PSU
    500w
    Case
    MT
    Cooling
    Dell Premium
    Keyboard
    Logitech wired
    Mouse
    Logitech wireless
    Internet Speed
    so slow I'm too embarrassed to tell
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
  • Operating System
    Windows 10 Pro 22H2 19045.3930
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 9020
    CPU
    i7-4770
    Memory
    24 gb
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    256 gb Toshiba BG4 M.2 NVE SSB and 1 tb hdd
    PSU
    500w
    Case
    MT
    Cooling
    Dell factory
    Mouse
    Logitech wireless
    Keyboard
    Logitech wired
    Internet Speed
    still not telling
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
The Pubic folders are intended for access by other users on the same computer not other computers.

File explorer's Network section has been faulty since Windows 10 Version 1803. I doubt that MS will ever fix it.
This comment of yours tells me that you have a real network setup problem rather than just the standard unreliability of File explorer's Network section.
Sometimes I can manually enter \\COMPUTERNAME in File Explorer and access another PC on the network directly, sometimes that fails too
This is how I set up my networks and I never have problems.
A consolidated network setup checklist for Windows 10 and 11 - my post #4 - TenForums

I don't want to encourage you to spend time on what I see as a distraction but there is another FDResPub suggestion in
Net Start-Stop FDResPub - MrEd post #12 - TenForums

I don't know what you mean by
Network app



Denis
 

My Computer

System One

  • OS
    Windows 11 Home x64 Version 23H2 Build 22631.3447
The Pubic folders are intended for access by other users on the same computer not other computers.
Actually, the user's Public folder is not shared with other computers on the network by default, but it is shared with other computers if you enable the "Public Folder Sharing" setting in Settings->Advanced Network Settings->Advanced Sharing Settings->All Networks. This is the how I am sharing it between the other computers on my network.

I don't know what you mean by "Network app"

I was referring to the Network icon that can be added to the desktop similar to This PC, Recycle Bin, Control Panel, etc.). These are configured in Settings->Personalization->Themes->Desktop Icon Settings. It ultimately results in an icon that simply launches File Explorer opened by default to the Network section.
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    MinisForum NAB6
    CPU
    Intel Core i7-12650H
    Memory
    64 GB
I find the best thing to do is NOT set all that.
Disable everything, except "file and printer sharing under Private Network".
Then just create a shortcut another computers like this...

\\PC_NAME

Now, on each computer, set the User folders and Public folders to NOT SHARED (They are just clutter, better to hide them).
Then on the folders you want shared set them to SHARED (and set access rights).

When you click on that shortcut above, you will get a nice list of all the shared folders on the other PC.
You just need one shortcut for each PC.
Nice and simple, no Windows mess.
My own theory on this is that there must be a local DNS on the network, I guess from the router, which means that just naming the PC works, without the need for Discovery. I am not an expert, but seems to make sense as to how it works.
 

My Computer

System One

  • OS
    Win 11
    Computer type
    PC/Desktop
    CPU
    12700
    Memory
    32gb
    Graphics Card(s)
    3070ti
    Sound Card
    -
    Screen Resolution
    3840x1600, 2560x1080
Back
Top Bottom