Solved Ethernet - normal download speed, very slow upload speed


dsscottage

Member
Local time
5:55 PM
Posts
38
OS
Win 11 Pro
I'm in the process of setting my my new computer and I have a problem with the Ethernet upload speed.

Running a speed test, my download speed is 900+ Mbps, my upload speed is 2 Mbps.

I disconnected the Ethernet connection and connected to WiFi and my download speed is 700+ Mbps, my upload speed is 35+ Mbps. These are the same speeds that are recorded on other computers on my network.

I connected the Ethernet cable to another computer and got normal speeds.

Therefore, I'm assuming that the Ethernet connection is at fault.

I ran the network and internet troubleshooters. It didn't find any problems.

I followed the instructions on the following link but that didn't work:

I reset the cable modem but that did nothing.

I removed and reinstalled the Ethernet driver but that didn't work.

I checked for a driver update but I have the latest driver.

I'm running Win 11 home with all updates

The Ethernet card is Killer E3100 2.5 Gigabit
The Ethernet driver version is 1125.13.424.2023

Is there anything else that I can try?
 

My Computer

System One

  • OS
    Win 11 Pro
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell
    CPU
    Intel i9-13900
    Motherboard
    Dell Inc. 0XD433 A01
    Memory
    Corsair Vengence DDR5 RAM 64GB (2x32GB)
    Graphics Card(s)
    Nvidia RTX 4800 16GB
    Sound Card
    Integrated
    Monitor(s) Displays
    LG 32UP83A-W
    Screen Resolution
    3840x2160
    Hard Drives
    2x 2TB M.2 PCI SSD (4TB total)
    PSU
    750W
    Case
    Dell
    Cooling
    Dell Performance liquid cooling
    Keyboard
    Dell KB522
    Mouse
    Logitech M310
    Internet Speed
    500Mb down, 35Mb up
    Browser
    Chrome
    Antivirus
    Windows Defender
The upload speed on broadband Internet connection always lower than download speed, not much you can do.
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    HP Pavilion
    CPU
    AMD Ryzen 7 5700G
    Motherboard
    Erica6
    Memory
    Micron Technology DDR4-3200 16GB
    Graphics Card(s)
    NVIDIA GeForce RTX 3060
    Sound Card
    Realtek ALC671
    Monitor(s) Displays
    Samsung SyncMaster U28E590
    Screen Resolution
    3840 x 2160
    Hard Drives
    SAMSUNG MZVLQ1T0HALB-000H1

My Computer

System One

  • OS
    Windows 11 Home
    Computer type
    PC/Desktop
    CPU
    AMD Ryzen 5 3600 & No fTPM (07/19)
    Motherboard
    MSI B450 TOMAHAWK 7C02v1E & IFX TPM (07/19)
    Memory
    4x 8GB ADATA XPG GAMMIX D10 DDR4 3200MHz CL16
    Graphics Card(s)
    MSI Radeon RX 580 ARMOR 8G OC @48FPS (08/19)
    Sound Card
    Creative Sound Blaster Z (11/16)
    Monitor(s) Displays
    24" AOC G2460VQ6 (01/19)
    Screen Resolution
    1920×1080@75Hz & FreeSync (DisplayPort)
    Hard Drives
    ADATA XPG GAMMIX S11 Pro SSD 512GB (07/19)
    PSU
    Seasonic M12II-520 80 Plus Bronze (11/16)
    Case
    Lian Li PC-7NB & 3x Noctua NF-S12A FLX@700rpm (11/16)
    Cooling
    CPU Cooler Noctua NH-U12S@700rpm (07/19)
    Keyboard
    HP Wired Desktop 320K + Rabalux 76017 Parker (01/24)
    Mouse
    Logitech M330 Silent Plus (04/23)
    Internet Speed
    400/40 Mbps via RouterOS (05/21) & TCP Optimizer
    Browser
    Edge (No FB/Google) & Brave for YouTube & LibreWolf for FB
    Antivirus
    NoAV & Binisoft WFC & NextDNS
    Other Info
    Headphones: Sennheiser RS170 (09/10)
    Phone: Samsung Galaxy Xcover 7 (02/24)
The upload speed on broadband Internet connection always lower than download speed, not much you can do.
I know that.

If I use a WiFi connection, I get 35+ Mbps upload. I get the same upload speed on 3 other computers in the household. It's only on the new computer using Ethernet that I get a max of 2 Mbps upload.

This makes the internet connection sluggish.
 

My Computer

System One

  • OS
    Win 11 Pro
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell
    CPU
    Intel i9-13900
    Motherboard
    Dell Inc. 0XD433 A01
    Memory
    Corsair Vengence DDR5 RAM 64GB (2x32GB)
    Graphics Card(s)
    Nvidia RTX 4800 16GB
    Sound Card
    Integrated
    Monitor(s) Displays
    LG 32UP83A-W
    Screen Resolution
    3840x2160
    Hard Drives
    2x 2TB M.2 PCI SSD (4TB total)
    PSU
    750W
    Case
    Dell
    Cooling
    Dell Performance liquid cooling
    Keyboard
    Dell KB522
    Mouse
    Logitech M310
    Internet Speed
    500Mb down, 35Mb up
    Browser
    Chrome
    Antivirus
    Windows Defender
Problem solved.

This doesn't make logical sense to me but here is the solution in case anyone else has this obscure problem.

I have:
-Dell XPS 8960
-Win 11 Home (up to date)
-Ethernet card is Killer E3100 2.5 Gigabit
-Ethernet driver version is 1125.13.424.2023

In short, my internet upload speed should have been about 35 Mbps. I had this speed while connected to WiFi (and all other computers on my network) but the speed was only 2 Mbps when connected to Ethernet.

In my shorthand, here is what I tried:
-reboot router and computer
-ran Window network troubleshooter
-ran Dell troubleshooter
-disconnected Ethernet, connected WiFi. I got 700+ Mbps down 35+ Mbs up
-connect Ethernet cable to another computer. I got 900+ Mbps down 35+Mbps up
-removed Ethernet adapter (from device manager) -rebooted to reinstall
-removed and reinstalled driver
-checked for updated driver (I have the latest driver)
-Win 11 is up to date

Nothing worked so I called Dell tech support and connected with a live technician.

It took a lengthy investigation but the tech ultimately disabled a number of Microsoft services that weren't necessary for normal operation. That fixed the problem.

I don't know which service was the problem and it doesn't make sense to me that it would have caused slow upload speed on ethernet but not WiFi. Regardless, it is fixed.
 

My Computer

System One

  • OS
    Win 11 Pro
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell
    CPU
    Intel i9-13900
    Motherboard
    Dell Inc. 0XD433 A01
    Memory
    Corsair Vengence DDR5 RAM 64GB (2x32GB)
    Graphics Card(s)
    Nvidia RTX 4800 16GB
    Sound Card
    Integrated
    Monitor(s) Displays
    LG 32UP83A-W
    Screen Resolution
    3840x2160
    Hard Drives
    2x 2TB M.2 PCI SSD (4TB total)
    PSU
    750W
    Case
    Dell
    Cooling
    Dell Performance liquid cooling
    Keyboard
    Dell KB522
    Mouse
    Logitech M310
    Internet Speed
    500Mb down, 35Mb up
    Browser
    Chrome
    Antivirus
    Windows Defender
Further information regarding this problem and solution in case anyone else has the issue.

I won't bore you with all the detail but the slow upload problem returned and I managed to find the specific problem.

My motherboard has an Intel Killer E3100G 2.5 Gigabit Ethernet Controller.
The drivers for this controller install a service called "Killer Network Services".
Killer Network Services was the cause of my slow upload (0.2 Mbps instead of 35 Mbps).
Disabling the service solved the problem.

The link above describes the service and says that it is not a necessary service.
 

My Computer

System One

  • OS
    Win 11 Pro
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell
    CPU
    Intel i9-13900
    Motherboard
    Dell Inc. 0XD433 A01
    Memory
    Corsair Vengence DDR5 RAM 64GB (2x32GB)
    Graphics Card(s)
    Nvidia RTX 4800 16GB
    Sound Card
    Integrated
    Monitor(s) Displays
    LG 32UP83A-W
    Screen Resolution
    3840x2160
    Hard Drives
    2x 2TB M.2 PCI SSD (4TB total)
    PSU
    750W
    Case
    Dell
    Cooling
    Dell Performance liquid cooling
    Keyboard
    Dell KB522
    Mouse
    Logitech M310
    Internet Speed
    500Mb down, 35Mb up
    Browser
    Chrome
    Antivirus
    Windows Defender
Back
Top Bottom