Solved Restoring Windows Security


Mark Phelps

Well-known member
Member
VIP
Local time
6:12 PM
Posts
428
OS
Windows 11
OK, I messed up ... I ran a third-party app to supposedly Disable Defender because it was causing my file migration tasks to slow to a crawl since it appeared to be scanning every .exe file -- and since I was doing a yearly offline backup, this amounted to TB of files.

But apparently, the app Removed it, instead, and maybe Windows Security as well.

Now that I am done with the backups, I want to get Defender and Windows Security back.

I looked in Settings and while Windows Security is not under Installed Apps, it is under Windows Components. So I opened the Advanced page and did both a Repair and Reset. But when I reopened Settings, Privacy and Security, Windows Security is not shown at the top right of the window.

So I found the tutorial here on using Powershell and ran that command, and restarted. But once again, when I checked Settings, Windows Security is not listed.

So, I did a Repair-Install of 22631.2715 but when I finally restarted, Windows Security is still not shown in Settings.

This is the PC I use as a local file and system backup server and the one that the December security update corrupted, so I have it running on build 2715 and have the Windows Update services disabled -- so clearly, I do not want to run Windows Update on this.

Don't know what else I can do.
 
Windows Build/Version
Win11 Pro build 22631.2715

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Custom built
    CPU
    Ryzen 5600X
    Motherboard
    ASRock Steel Legend
    Memory
    16GB
    Graphics Card(s)
    EVGA GT 710
    Sound Card
    None
    Monitor(s) Displays
    23",24", 19" - flat panels
    Screen Resolution
    1920x1200
    Hard Drives
    None - only M.2 SATA and NVMe drives
    PSU
    750W
    Case
    Antec
    Cooling
    stock Wraith cooler
    Keyboard
    Corsair gaming
    Mouse
    Logitech M720
    Internet Speed
    1Gb
Sounds like a reset or reinstall, that or contact the developer of the app and ask what it does to "disable defender".
 

My Computer

System One

  • OS
    Windows 11
Now that I am done with the backups, I want to get Defender and Windows Security back.


Do you still have a backup from before you ran the 3rd party tool?
If so... it might be easier to just restore that.
 

My Computers

System One System Two

  • OS
    Win 11 Home ♦♦♦22631.3527 ♦♦♦♦♦♦♦23H2
    Computer type
    PC/Desktop
    Manufacturer/Model
    Built by Ghot® [May 2020]
    CPU
    AMD Ryzen 7 3700X
    Motherboard
    Asus Pro WS X570-ACE (BIOS 4702)
    Memory
    G.Skill (F4-3200C14D-16GTZKW)
    Graphics Card(s)
    EVGA RTX 2070 (08G-P4-2171-KR)
    Sound Card
    Realtek ALC1220P / ALC S1220A
    Monitor(s) Displays
    Dell U3011 30"
    Screen Resolution
    2560 x 1600
    Hard Drives
    2x Samsung 860 EVO 500GB,
    WD 4TB Black FZBX - SATA III,
    WD 8TB Black FZBX - SATA III,
    DRW-24B1ST CD/DVD Burner
    PSU
    PC Power & Cooling 750W Quad EPS12V
    Case
    Cooler Master ATCS 840 Tower
    Cooling
    CM Hyper 212 EVO (push/pull)
    Keyboard
    Ducky DK9008 Shine II Blue LED
    Mouse
    Logitech Optical M-100
    Internet Speed
    300/300
    Browser
    Firefox (latest)
    Antivirus
    Bitdefender Internet Security
    Other Info
    Speakers: Klipsch Pro Media 2.1
  • Operating System
    Windows XP Pro 32bit w/SP3
    Computer type
    PC/Desktop
    Manufacturer/Model
    Built by Ghot® (not in use)
    CPU
    AMD Athlon 64 X2 5000+ (OC'd @ 3.2Ghz)
    Motherboard
    ASUS M2N32-SLI Deluxe Wireless Edition
    Memory
    TWIN2X2048-6400C4DHX (2 x 1GB, DDR2 800)
    Graphics card(s)
    EVGA 256-P2-N758-TR GeForce 8600GT SSC
    Sound Card
    Onboard
    Monitor(s) Displays
    ViewSonic G90FB Black 19" Professional (CRT)
    Screen Resolution
    up to 2048 x 1536
    Hard Drives
    WD 36GB 10,000rpm Raptor SATA
    Seagate 80GB 7200rpm SATA
    Lite-On LTR-52246S CD/RW
    Lite-On LH-18A1P CD/DVD Burner
    PSU
    PC Power & Cooling Silencer 750 Quad EPS12V
    Case
    Generic Beige case, 80mm fans
    Cooling
    ZALMAN 9500A 92mm CPU Cooler
    Mouse
    Logitech Optical M-BT96a
    Keyboard
    Logitech Classic Keybooard 200
    Internet Speed
    300/300
    Browser
    Firefox 3.x ??
    Antivirus
    Symantec (Norton)
    Other Info
    Still assembled, still runs. Haven't turned it on for 13 years?
I ran a third-party app
Could you expand on this a bit and say what 3rd party app you used to disable defender? Where did you obtain this app? Was it from a reliable source?
Do you currently have any 3rd party AV installed or did you have a 3rd party AV installed?If so, what AV?
A repair install will only fix Windows files, registry, processes, and services. It will not affect, repair, or override anything caused by installed application nor anything in a user account. That said, since a repair install did not fix the issue, IMO it points to something left behind by a third party app. That could be the rogue app you used OR third party AV.
 

My Computers

System One System Two

  • OS
    Windows 11 Pro 23H2 22631.3447
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 7080
    CPU
    i9-10900 10 core 20 threads
    Motherboard
    DELL 0J37VM
    Memory
    32 gb
    Graphics Card(s)
    none-Intel UHD Graphics 630
    Sound Card
    Integrated Realtek
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    1tb Solidigm m.2 +256gb ssd+512 gb usb m.2 sata
    PSU
    500w
    Case
    MT
    Cooling
    Dell Premium
    Keyboard
    Logitech wired
    Mouse
    Logitech wireless
    Internet Speed
    so slow I'm too embarrassed to tell
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
  • Operating System
    Windows 10 Pro 22H2 19045.3930
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 9020
    CPU
    i7-4770
    Memory
    24 gb
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    256 gb Toshiba BG4 M.2 NVE SSB and 1 tb hdd
    PSU
    500w
    Case
    MT
    Cooling
    Dell factory
    Mouse
    Logitech wireless
    Keyboard
    Logitech wired
    Internet Speed
    still not telling
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
Could you expand on this a bit and say what 3rd party app you used to disable defender? Where did you obtain this app? Was it from a reliable source?
Do you currently have any 3rd party AV installed or did you have a 3rd party AV installed?If so, what AV?
A repair install will only fix Windows files, registry, processes, and services. It will not affect, repair, or override anything caused by installed application nor anything in a user account. That said, since a repair install did not fix the issue, IMO it points to something left behind by a third party app. That could be the rogue app you used OR third party AV.
The tool is Windows Defender Remover and it is from:
GitHub - ionuttbara/windows-defender-remover: A tool which is uses to remove Windows Defender in Windows 8.x, Windows 10 (every version) and Windows 11.

I don't have any third-party AV product installed.

I have not tried removing that app -- that is the next thing to do.

I have been using this since September -- but only do complete system archives the end of the year, so I did not notice any problems before.

I can't do a clean-install because the PC is using a one-time activation key.
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Custom built
    CPU
    Ryzen 5600X
    Motherboard
    ASRock Steel Legend
    Memory
    16GB
    Graphics Card(s)
    EVGA GT 710
    Sound Card
    None
    Monitor(s) Displays
    23",24", 19" - flat panels
    Screen Resolution
    1920x1200
    Hard Drives
    None - only M.2 SATA and NVMe drives
    PSU
    750W
    Case
    Antec
    Cooling
    stock Wraith cooler
    Keyboard
    Corsair gaming
    Mouse
    Logitech M720
    Internet Speed
    1Gb
Do you still have a backup from before you ran the 3rd party tool?
If so... it might be easier to just restore that.
I do, but that was MONTHS ago, and I would have to get stuff ready to make recent updates if I do that.

But ... that is something to think about. Thanks
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Custom built
    CPU
    Ryzen 5600X
    Motherboard
    ASRock Steel Legend
    Memory
    16GB
    Graphics Card(s)
    EVGA GT 710
    Sound Card
    None
    Monitor(s) Displays
    23",24", 19" - flat panels
    Screen Resolution
    1920x1200
    Hard Drives
    None - only M.2 SATA and NVMe drives
    PSU
    750W
    Case
    Antec
    Cooling
    stock Wraith cooler
    Keyboard
    Corsair gaming
    Mouse
    Logitech M720
    Internet Speed
    1Gb
Did you run the developer’s command to enable Defender?
 

My Computers

System One System Two

  • OS
    Windows 11 Pro 23H2 [rev. 3447]
    Computer type
    PC/Desktop
    Manufacturer/Model
    Intel NUC12WSHi7
    CPU
    12th Gen Intel Core i7-1260P, 2100 MHz
    Motherboard
    NUC12WSBi7
    Memory
    64 GB
    Graphics Card(s)
    Intel Iris Xe
    Sound Card
    built-in Realtek HD audio
    Monitor(s) Displays
    Dell U3219Q
    Screen Resolution
    3840x2160 @ 60Hz
    Hard Drives
    Samsung SSD 990 PRO 1TB
    Keyboard
    CODE 104-Key Mechanical Keyboard with Cherry MX Clears
  • Operating System
    Linux Mint 21.2 (Cinnamon)
    Computer type
    PC/Desktop
    Manufacturer/Model
    Intel NUC8i5BEH
    CPU
    Intel Core i5-8259U CPU @ 2.30GHz
    Memory
    32 GB
    Graphics card(s)
    Iris Plus 655
    Keyboard
    CODE 104-Key Mechanical Keyboard - Cherry MX Clear
Did you run the developer’s command to enable Defender?
The screen puts up a menu with options to restore Defender and/or Windows Security. I selected each of the two -- but have not seen any changes.

I don't see any information regarding any developer commands.
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Custom built
    CPU
    Ryzen 5600X
    Motherboard
    ASRock Steel Legend
    Memory
    16GB
    Graphics Card(s)
    EVGA GT 710
    Sound Card
    None
    Monitor(s) Displays
    23",24", 19" - flat panels
    Screen Resolution
    1920x1200
    Hard Drives
    None - only M.2 SATA and NVMe drives
    PSU
    750W
    Case
    Antec
    Cooling
    stock Wraith cooler
    Keyboard
    Corsair gaming
    Mouse
    Logitech M720
    Internet Speed
    1Gb
Update: I got fed up with the issues and replaced the install with Tiny11 -- and that works great. Able to do Defender exclusions without any issues. Marking this as solved.
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Custom built
    CPU
    Ryzen 5600X
    Motherboard
    ASRock Steel Legend
    Memory
    16GB
    Graphics Card(s)
    EVGA GT 710
    Sound Card
    None
    Monitor(s) Displays
    23",24", 19" - flat panels
    Screen Resolution
    1920x1200
    Hard Drives
    None - only M.2 SATA and NVMe drives
    PSU
    750W
    Case
    Antec
    Cooling
    stock Wraith cooler
    Keyboard
    Corsair gaming
    Mouse
    Logitech M720
    Internet Speed
    1Gb
I had a similar experience. I worked with Microsoft Support and was told many users developed similar issues and a fix is in work and will be part of some future Windows update.
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Self Built

Latest Support Threads

Back
Top Bottom