Can't reinstall Microsoft Store


FailSafeNow

New member
Local time
8:55 AM
Posts
23
OS
Windows 11 Pro
I'm getting nowhere on this particular problem. I try to install the Microsoft Store via the Powershell. Whether I'm using a downloaded file or using the URL, it doesn't matter. I get this:

Add-AppxPackage : Deployment failed with HRESULT: 0x80073CF6, Package could not be registered. An internal error occurred with error 0x80073D05. See http://go.microsoft.com/fwlink/?LinkId=235160 for help diagnosing app deployment issues. NOTE: For additional information, look for [ActivityId] fd0c2f4e-1cbb-0006-78a3-0dfdbb1cda01 in the Event Log or use the command line Get-AppPackageLog -ActivityID fd0c2f4e-1cbb-0006-78a3-0dfdbb1cda01 At line:1 char:62 + ... | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.I ... + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ + CategoryInfo : WriteError: (C:\Program File...ppXManifest.xml:String) [Add-AppxPackage], IOException + FullyQualifiedErrorId : DeploymentError,Microsoft.Windows.Appx.PackageManager.Commands.AddAppxPackageCommand

I'm to the point where I can double-click the thing and try to install it the user-friendly way, but that fails, too.

This app package is not supported for installation by App Installer because it uses certain restricted capabilities.

Someone said the thing to do is go into the Credentials Manager and make some changes. But I can't.

Credential Manager Error An error occurred while performing this action. Error code: 0x80070425 Error Message: The service cannot accept control messages at this time.

Someone said to try to start the credentials manager service manually. But that fails with an Error 5. Someone said you can fix that by changing permissions on the Credentials folder in appdata > roaming, but it's just not true. I did that. I took full ownership of the folder. I even extended full control to Everyone. It didn't do me any good.

I'm all out of ideas. Can you help me? Thanks.
 

My Computer

System One

  • OS
    Windows 11 Pro
    Computer type
    Laptop
    Manufacturer/Model
    Dell
Hello, :alien:

You can see if an option in the tutorial below may reinstall the Microsoft Store app for you.

 

My Computers

System One System Two

  • OS
    Windows 11 Pro for Workstations
    Computer type
    PC/Desktop
    Manufacturer/Model
    Custom self build
    CPU
    Intel i7-8700K 5 GHz
    Motherboard
    ASUS ROG Maximus XI Formula Z390
    Memory
    64 GB (4x16GB) G.SKILL TridentZ RGB DDR4 3600 MHz (F4-3600C18D-32GTZR)
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING (11GB GDDR5X)
    Sound Card
    Integrated Digital Audio (S/PDIF)
    Monitor(s) Displays
    2 x Samsung Odyssey G75 27"
    Screen Resolution
    2560x1440
    Hard Drives
    1TB Samsung 990 PRO M.2,
    4TB Samsung 990 PRO M.2,
    8TB WD MyCloudEX2Ultra NAS
    PSU
    Seasonic Prime Titanium 850W
    Case
    Thermaltake Core P3 wall mounted
    Cooling
    Corsair Hydro H115i
    Keyboard
    Logitech wireless K800
    Mouse
    Logitech MX Master 3
    Internet Speed
    1 Gbps Download and 35 Mbps Upload
    Browser
    Google Chrome
    Antivirus
    Microsoft Defender and Malwarebytes Premium
    Other Info
    Logitech Z625 speaker system,
    Logitech BRIO 4K Pro webcam,
    HP Color LaserJet Pro MFP M477fdn,
    APC SMART-UPS RT 1000 XL - SURT1000XLI,
    Galaxy S23 Plus phone
  • Operating System
    Windows 11 Pro
    Computer type
    Laptop
    Manufacturer/Model
    HP Spectre x360 2in1 14-eu0098nr (2024)
    CPU
    Intel Core Ultra 7 155H 4.8 GHz
    Memory
    16 GB LPDDR5x-7467 MHz
    Graphics card(s)
    Integrated Intel Arc
    Sound Card
    Poly Studio
    Monitor(s) Displays
    14" 2.8K OLED multitouch
    Screen Resolution
    2880 x 1800
    Hard Drives
    2 TB PCIe NVMe M.2 SSD
    Internet Speed
    Intel Wi-Fi 7 BE200 (2x2) and Bluetooth 5.4
    Browser
    Chrome and Edge
    Antivirus
    Windows Defender and Malwarebytes Premium

uninstall you whatever you've attempted to install > reboot > go to above link > scroll down > download the "Windows 11 Store.msixbundle" > double click to install
 

My Computer

System One

  • OS
    Windows 11 Pro

uninstall you whatever you've attempted to install > reboot > go to above link > scroll down > download the "Windows 11 Store.msixbundle" > double click to install
That version at least starts to install. But then it fails.
App installation failed with error message: An internal error occurred with error 0x80073D05. See http://go.microsoft.com/fwlink/?LinkId=235160 for help diagnosing app deployment issues. (0x80073d05)
Here's the version where I try to do it through the Powershell:
Add-AppPackage : Deployment failed with HRESULT: 0x80073CF6, Package could not be registered. An internal error occurred with error 0x80073D05. See http://go.microsoft.com/fwlink/?LinkId=235160 for help diagnosing app deployment issues. NOTE: For additional information, look for [ActivityId] 870951b3-1cc3-0007-82dc-0a87c31cda01 in the Event Log or use the command line Get-AppPackageLog -ActivityID 870951b3-1cc3-0007-82dc-0a87c31cda01 At line:1 char:1 + Add-AppPackage -Path "G:\G Folder\Downloads\Windows 11 Store.msixbund ... + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ + CategoryInfo : WriteError: (G:\G Folder\Dow...tore.msixbundle:String) [Add-AppxPackage], IOException + FullyQualifiedErrorId : DeploymentError,Microsoft.Windows.Appx.PackageManager.Commands.AddAppxPackageCommand
 

My Computer

System One

  • OS
    Windows 11 Pro
    Computer type
    Laptop
    Manufacturer/Model
    Dell
Hello, :alien:

You can see if an option in the tutorial below may reinstall the Microsoft Store app for you.

wsreset does nothing, except open a dialog that tells me an app needs to be installed.
We can't open this 'ms-windows-store• link Your device needs a new app to open this link.
And winget seems to get stuck. The thing stops spinning after a few seconds. I wish it had an option for verbose output, so I could see exactly where it was getting stuck. But no such luck.
 

My Computer

System One

  • OS
    Windows 11 Pro
    Computer type
    Laptop
    Manufacturer/Model
    Dell
powershell as admin >
Code:
Get-AppxPackage *windowsstore* | Remove-AppxPackage
> reboot then run that msixbundle
 

My Computer

System One

  • OS
    Windows 11 Pro
powershell as admin >
Code:
Get-AppxPackage *windowsstore* | Remove-AppxPackage
> reboot then run that msixbundle
No dice. Same errors.

You ever feel like you're cursed? I do.
 

My Computer

System One

  • OS
    Windows 11 Pro
    Computer type
    Laptop
    Manufacturer/Model
    Dell
if none of these are working its because whatever is there is not fully uninstalled. i have removed and reinstalled the store using that bundle from winaero's page on multiple machines. after uninstalling with powershell, run the get package powershell command and see what remnants of store show in the list of apps
 

My Computer

System One

  • OS
    Windows 11 Pro
Code:
Get-AppxPackage -AllUsers *windowsstore* | Remove-AppxPackage

Otherwise you're not removing it for All Users, and the existing package won't be uninstalled.
 

My Computer

System One

  • OS
    Windows 7
if none of these are working its because whatever is there is not fully uninstalled. i have removed and reinstalled the store using that bundle from winaero's page on multiple machines. after uninstalling with powershell, run the get package powershell command and see what remnants of store show in the list of apps
You mean this one?
Get-AppxPackage *windowsstore* | Remove-AppxPackage
If that's the one, here's what it tells me:
PS C:\WINDOWS\system32> Get-AppxPackage *windowsstore* | Remove-AppxPackage PS C:\WINDOWS\system32>
Whole lotta nothing.
 

My Computer

System One

  • OS
    Windows 11 Pro
    Computer type
    Laptop
    Manufacturer/Model
    Dell
if none of these are working its because whatever is there is not fully uninstalled. i have removed and reinstalled the store using that bundle from winaero's page on multiple machines. after uninstalling with powershell, run the get package powershell command and see what remnants of store show in the list of apps

Code:
Get-AppxPackage -AllUsers *windowsstore* | Remove-AppxPackage

Otherwise you're not removing it for All Users, and the existing package won't be uninstalled.



When I uninstalled MS Store... I completely uninstalled it.
Even MS couldn't get it back.


So...

I took my troubles down to Madame Ruth
You know that gypsy with the gold-capped tooth
She's got a pad down on Thirty-Fourth and Vine
Sellin' little bottles of Solution Number Nine







Here's the original topic... (this was quite a few updates ago, and on Windows 10)

 

My Computers

System One System Two

  • OS
    Win 11 Home ♦♦♦22631.3235 ♦♦♦♦♦♦♦23H2
    Computer type
    PC/Desktop
    Manufacturer/Model
    Built by Ghot® [May 2020]
    CPU
    AMD Ryzen 7 3700X
    Motherboard
    Asus Pro WS X570-ACE (BIOS 4702)
    Memory
    G.Skill (F4-3200C14D-16GTZKW)
    Graphics Card(s)
    EVGA RTX 2070 (08G-P4-2171-KR)
    Sound Card
    Realtek ALC1220P / ALC S1220A
    Monitor(s) Displays
    Dell U3011 30"
    Screen Resolution
    2560 x 1600
    Hard Drives
    2x Samsung 860 EVO 500GB,
    WD 4TB Black FZBX - SATA III,
    WD 8TB Black FZBX - SATA III,
    DRW-24B1ST CD/DVD Burner
    PSU
    PC Power & Cooling 750W Quad EPS12V
    Case
    Cooler Master ATCS 840 Tower
    Cooling
    CM Hyper 212 EVO (push/pull)
    Keyboard
    Ducky DK9008 Shine II Blue LED
    Mouse
    Logitech Optical M-100
    Internet Speed
    300/300
    Browser
    Firefox (latest)
    Antivirus
    Bitdefender Internet Security
    Other Info
    Speakers: Klipsch Pro Media 2.1
  • Operating System
    Windows XP Pro 32bit w/SP3
    Computer type
    PC/Desktop
    Manufacturer/Model
    Built by Ghot® (not in use)
    CPU
    AMD Athlon 64 X2 5000+ (OC'd @ 3.2Ghz)
    Motherboard
    ASUS M2N32-SLI Deluxe Wireless Edition
    Memory
    TWIN2X2048-6400C4DHX (2 x 1GB, DDR2 800)
    Graphics card(s)
    EVGA 256-P2-N758-TR GeForce 8600GT SSC
    Sound Card
    Onboard
    Monitor(s) Displays
    ViewSonic G90FB Black 19" Professional (CRT)
    Screen Resolution
    up to 2048 x 1536
    Hard Drives
    WD 36GB 10,000rpm Raptor SATA
    Seagate 80GB 7200rpm SATA
    Lite-On LTR-52246S CD/RW
    Lite-On LH-18A1P CD/DVD Burner
    PSU
    PC Power & Cooling Silencer 750 Quad EPS12V
    Case
    Generic Beige case, 80mm fans
    Cooling
    ZALMAN 9500A 92mm CPU Cooler
    Mouse
    Logitech Optical M-BT96a
    Keyboard
    Logitech Classic Keybooard 200
    Internet Speed
    300/300
    Browser
    Firefox 3.x ??
    Antivirus
    Symantec (Norton)
    Other Info
    Still assembled, still runs. Haven't turned it on for 13 years?

    http://www.xtremesystems.org/forums/showthread.php?183088-5000-B-E-on-M2N32-SLI-Dlx-Overclocked&p=2891724#post2891724
A while back I completely uninstalled MS Store, then wanted it back.
Nothing would work. Finally, solution #9 worked, here...




I took my troubles down to Madame Ruth
You know that gypsy with the gold-capped tooth
She's got a pad down on Thirty-Fourth and Vine
Sellin' little bottles of Solution Number Nine

I told her that I was a flop with fix
I've been this way since 1956
She looked at my palm and she made a magic sign
She said "What you need is Solution Number Nine"
She bent down and turned around and gave me a wink
She said "I'm gonna make it up right here in the sink"
It smelled like turpentine, it looked like India ink
I held my nose, I closed my eyes, I took a drink

I didn't know if it was day or night
I started fixin' everything in sight
But when I fixed a cop down on Thirty-Fourth and Vine
He broke my little bottle of Solution Number Nine

I held my nose, I closed my eyes, I took a drink
I didn't know if it was day or night
I started fixin' everything in sight
But when I fixed a cop down on Thirty-Fourth and Vine
He broke my little bottle of Solution Number Nine
Solution Number Nine
Solution Number Nine
Solution Number Nine :D



That's a lot of solutions. Maybe one of them will work. I'll try them.
 

My Computer

System One

  • OS
    Windows 11 Pro
    Computer type
    Laptop
    Manufacturer/Model
    Dell
That's a lot of solutions. Maybe one of them will work. I'll try them.



I tried them ALL.
The one that worked.... So-lution Number N-i-i-i-ne. :-)

But as I mentioned above... when I uninstalled MS Store, it was like it never existed.
I have a double barrel .45 caliber uninstaller. :D
 

My Computers

System One System Two

  • OS
    Win 11 Home ♦♦♦22631.3235 ♦♦♦♦♦♦♦23H2
    Computer type
    PC/Desktop
    Manufacturer/Model
    Built by Ghot® [May 2020]
    CPU
    AMD Ryzen 7 3700X
    Motherboard
    Asus Pro WS X570-ACE (BIOS 4702)
    Memory
    G.Skill (F4-3200C14D-16GTZKW)
    Graphics Card(s)
    EVGA RTX 2070 (08G-P4-2171-KR)
    Sound Card
    Realtek ALC1220P / ALC S1220A
    Monitor(s) Displays
    Dell U3011 30"
    Screen Resolution
    2560 x 1600
    Hard Drives
    2x Samsung 860 EVO 500GB,
    WD 4TB Black FZBX - SATA III,
    WD 8TB Black FZBX - SATA III,
    DRW-24B1ST CD/DVD Burner
    PSU
    PC Power & Cooling 750W Quad EPS12V
    Case
    Cooler Master ATCS 840 Tower
    Cooling
    CM Hyper 212 EVO (push/pull)
    Keyboard
    Ducky DK9008 Shine II Blue LED
    Mouse
    Logitech Optical M-100
    Internet Speed
    300/300
    Browser
    Firefox (latest)
    Antivirus
    Bitdefender Internet Security
    Other Info
    Speakers: Klipsch Pro Media 2.1
  • Operating System
    Windows XP Pro 32bit w/SP3
    Computer type
    PC/Desktop
    Manufacturer/Model
    Built by Ghot® (not in use)
    CPU
    AMD Athlon 64 X2 5000+ (OC'd @ 3.2Ghz)
    Motherboard
    ASUS M2N32-SLI Deluxe Wireless Edition
    Memory
    TWIN2X2048-6400C4DHX (2 x 1GB, DDR2 800)
    Graphics card(s)
    EVGA 256-P2-N758-TR GeForce 8600GT SSC
    Sound Card
    Onboard
    Monitor(s) Displays
    ViewSonic G90FB Black 19" Professional (CRT)
    Screen Resolution
    up to 2048 x 1536
    Hard Drives
    WD 36GB 10,000rpm Raptor SATA
    Seagate 80GB 7200rpm SATA
    Lite-On LTR-52246S CD/RW
    Lite-On LH-18A1P CD/DVD Burner
    PSU
    PC Power & Cooling Silencer 750 Quad EPS12V
    Case
    Generic Beige case, 80mm fans
    Cooling
    ZALMAN 9500A 92mm CPU Cooler
    Mouse
    Logitech Optical M-BT96a
    Keyboard
    Logitech Classic Keybooard 200
    Internet Speed
    300/300
    Browser
    Firefox 3.x ??
    Antivirus
    Symantec (Norton)
    Other Info
    Still assembled, still runs. Haven't turned it on for 13 years?

    http://www.xtremesystems.org/forums/showthread.php?183088-5000-B-E-on-M2N32-SLI-Dlx-Overclocked&p=2891724#post2891724
I uninstalled MS Store, it was like it never existed.
I uninstalled the Store a few Builds back, haven't seen it since.
 
Last edited:

My Computers

System One System Two

  • OS
    Windows 10/11
    Computer type
    PC/Desktop
    Manufacturer/Model
    ASUS ROG Strix
  • Operating System
    Windows 11
    Computer type
    Laptop
    Manufacturer/Model
    ASUS VivoBook
There was another topic like this... on Eleven Forum about MS Store on Win 11.
Solution #9, didn't work for them... but eventually they got it back... might want to try and find that thread.

It seems like it was about 2 maybe three weeks ago?

I found it... slightly different issue. Had to do with Win 11 Beta... might be something in there that would help?

 

My Computers

System One System Two

  • OS
    Win 11 Home ♦♦♦22631.3235 ♦♦♦♦♦♦♦23H2
    Computer type
    PC/Desktop
    Manufacturer/Model
    Built by Ghot® [May 2020]
    CPU
    AMD Ryzen 7 3700X
    Motherboard
    Asus Pro WS X570-ACE (BIOS 4702)
    Memory
    G.Skill (F4-3200C14D-16GTZKW)
    Graphics Card(s)
    EVGA RTX 2070 (08G-P4-2171-KR)
    Sound Card
    Realtek ALC1220P / ALC S1220A
    Monitor(s) Displays
    Dell U3011 30"
    Screen Resolution
    2560 x 1600
    Hard Drives
    2x Samsung 860 EVO 500GB,
    WD 4TB Black FZBX - SATA III,
    WD 8TB Black FZBX - SATA III,
    DRW-24B1ST CD/DVD Burner
    PSU
    PC Power & Cooling 750W Quad EPS12V
    Case
    Cooler Master ATCS 840 Tower
    Cooling
    CM Hyper 212 EVO (push/pull)
    Keyboard
    Ducky DK9008 Shine II Blue LED
    Mouse
    Logitech Optical M-100
    Internet Speed
    300/300
    Browser
    Firefox (latest)
    Antivirus
    Bitdefender Internet Security
    Other Info
    Speakers: Klipsch Pro Media 2.1
  • Operating System
    Windows XP Pro 32bit w/SP3
    Computer type
    PC/Desktop
    Manufacturer/Model
    Built by Ghot® (not in use)
    CPU
    AMD Athlon 64 X2 5000+ (OC'd @ 3.2Ghz)
    Motherboard
    ASUS M2N32-SLI Deluxe Wireless Edition
    Memory
    TWIN2X2048-6400C4DHX (2 x 1GB, DDR2 800)
    Graphics card(s)
    EVGA 256-P2-N758-TR GeForce 8600GT SSC
    Sound Card
    Onboard
    Monitor(s) Displays
    ViewSonic G90FB Black 19" Professional (CRT)
    Screen Resolution
    up to 2048 x 1536
    Hard Drives
    WD 36GB 10,000rpm Raptor SATA
    Seagate 80GB 7200rpm SATA
    Lite-On LTR-52246S CD/RW
    Lite-On LH-18A1P CD/DVD Burner
    PSU
    PC Power & Cooling Silencer 750 Quad EPS12V
    Case
    Generic Beige case, 80mm fans
    Cooling
    ZALMAN 9500A 92mm CPU Cooler
    Mouse
    Logitech Optical M-BT96a
    Keyboard
    Logitech Classic Keybooard 200
    Internet Speed
    300/300
    Browser
    Firefox 3.x ??
    Antivirus
    Symantec (Norton)
    Other Info
    Still assembled, still runs. Haven't turned it on for 13 years?

    http://www.xtremesystems.org/forums/showthread.php?183088-5000-B-E-on-M2N32-SLI-Dlx-Overclocked&p=2891724#post2891724
That's a lot of solutions. Maybe one of them will work. I'll try them.
I tried all the approaches I hadn't already tried, ignoring any that required the store already being installed. No luck. Still failing, and still for the same reasons.
 

My Computer

System One

  • OS
    Windows 11 Pro
    Computer type
    Laptop
    Manufacturer/Model
    Dell
Below is the correct thread i think...was on Beta Build indeed.

Option Two is what worked for me:

 

My Computers

System One System Two

  • OS
    Windows 11 Pro 22631.3155(VHDX)/ Windows 11 Beta 22635.3212/Win 11 Dev 24H2(VHDX)
    Computer type
    Laptop
    Manufacturer/Model
    Lenovo
    CPU
    Intel Celeron N4000 @ 1.10GHz Gemini Lake 14nm
    Motherboard
    LENOVO LNVNB161216 (U3E1)
    Memory
    8GB Ram
    Graphics Card(s)
    Intel UHD Graphics 600 (Lenovo)
    Sound Card
    Realtek High Definition Audio Intel Display Audio
    Monitor(s) Displays
    Generic PnP Monitor (1920x1080@60Hz)
    Screen Resolution
    1920x1080
    Hard Drives
    512GB Western Digital WDC PC SN530 SDBPMPZ-512G-1101 (Unknown (SSD))
    Keyboard
    Laptop Keyboard
    Mouse
    G5 Gaming Mouse
    Internet Speed
    50mbps/50mbps
    Browser
    Chrome/Edge
    Antivirus
    Microsoft Defender
  • Computer type
    Laptop
    Manufacturer/Model
    Lenovo
    CPU
    Intel Celeron N4000 @ 1.10GHz Gemini Lake 14nm
    Motherboard
    LENOVO LNVNB161216 (U3E1)
    Memory
    8GB Ram
    Graphics card(s)
    Intel UHD Graphics 600 (Lenovo)
    Sound Card
    Realtek High Definition Audio Intel Display Audio
    Monitor(s) Displays
    Generic PnP Monitor (1920x1080@60Hz)
    Screen Resolution
    1920x1080
    Mouse
    G5 Gaming Mouse
    Keyboard
    Laptop Keyboard
    Internet Speed
    50mbps/50mbps
    Browser
    Chrome/Edge
    Antivirus
    Microsoft Defender
I uninstalled the Store a few Builds back, haven't seen it since.
I mean, everything in there relates to HAVING the Microsoft Store and it not working. For me:
Microsoft-Store {
have = false;
}
 

My Computer

System One

  • OS
    Windows 11 Pro
    Computer type
    Laptop
    Manufacturer/Model
    Dell
Below is the correct thread i think...was on Beta Build indeed.

Option Two is what worked for me:

But I've already tried both of those things. And I tried them again. I mean, at this point, it's not even again; it's more like again again again again again. And it still does not work, not one bit.
 

My Computer

System One

  • OS
    Windows 11 Pro
    Computer type
    Laptop
    Manufacturer/Model
    Dell
This entry in your first post bugs me;
Code:
Add-AppPackage -Path "G:\G Folder\Downloads\Windows 11 Store.msixbund
followed by:
Code:
WriteError: (G:\G Folder\Dow...tore.msixbundle:String) [Add-AppxPackage], IOException

Do you actually have a G: drive with the correct permissions?
And why would an attempt at a MS Store installation take place on your G: drive?
Could you please post what command(s) and from where you ran them?
Also did you try to change regions by any chance? (this could cause the winget to spin for ever if set to a mismatched region)
 

My Computers

System One System Two

  • OS
    Win11 All /Debian/Arch
    Computer type
    Laptop
    Manufacturer/Model
    ASUSTeK COMPUTER INC. TUF Gaming FX705GM
    CPU
    2.20 gigahertz Intel i7-8750H Hyper-threaded 12 cores
    Motherboard
    ASUSTeK COMPUTER INC. FX705GM 1.0
    Memory
    24428 Megabytes
    Graphics Card(s)
    Intel(R) UHD Graphics 630 / NVIDIA GeForce GTX 1060
    Sound Card
    Intel(R) Display Audio / Realtek(R) Audio
    Monitor(s) Displays
    Integrated Monitor (17.3"vis)
    Screen Resolution
    FHD 1920X1080 16:9
    Hard Drives
    2 SSD SATA/NVM Express 1.3
    WDS500G2B0A-00SM50 500.1 GB
    WDCSDAPNUW-1002 256 GB
    PSU
    19V DC 6.32 A 120 W
    Cooling
    Dual Fans
    Mouse
    MS Bluetooth
    Internet Speed
    Fiber 1GB Cox -us & ADSL Bouygues -fr
    Browser
    Edge Canary- Firefox Nightly
    Antivirus
    Windows Defender
    Other Info
    VMs of Windows 11 stable/Beta/Dev/Canary
    VM of XeroLinux- Arch based & Debian 12
  • Operating System
    Windows 11 Insider Canary
    Computer type
    Laptop
    Manufacturer/Model
    ASUS X751BP
    CPU
    AMD Dual Core A6-9220
    Motherboard
    ASUS
    Memory
    8 GB
    Graphics card(s)
    AMD Radeon R5 M420
    Sound Card
    Realtek
    Monitor(s) Displays
    17.3
    Screen Resolution
    1600X900 16:9
    Hard Drives
    1TB 5400RPM

Latest Support Threads

Back
Top Bottom