Locked out of my Outlook account


MrYossu

Active member
Member
Local time
11:08 AM
Posts
102
OS
Win11
Not sure if this is on-topic for this site, but thought I'd give it a go in case anyone can help.

I have an outlook.com email which I've been using for years, never changed the password or anything (OK, not the best idea, but it's the way it is). I use Thunderbird on Windows 11 to access this account, along with a few others.

Just today, Thunderbird started giving errors that it couldn't log in with this account. I went to outlook.com to try and log in there, and after a huge struggle with it, managed to change my password.

However, it then insisted on adding a related email. I tried to use the one I'd had associated with it before (same name but @gmail.com instead of @outlook.com), but it told me I couldn't as that was already a Microsoft account.

After going round in circles for some time, I finally gave up and chose the option to create a new outlook address.

Now when I try to log in to the original outlook.com address, it logs me in to the new one, and I can't persuade it to log me in to the original.

It seems that it's added the new email as an alias for the old one, as I can see if I try to change the alias...

1709155355091.png

However, logging in with the original credentials takes me to a new empty account, not the original.

I tried to remove the alias, but it won't let me, as it gives the following message...

1709155296947.png

Is there anything I can do, or have I lost access to the old one?

Thanks for any help you can give.
 

My Computer

System One

  • OS
    Win11
    CPU
    AMD Ryzen 9 3900X
    Motherboard
    Aorus X570 Elite
    Memory
    96Gb
    Graphics Card(s)
    2047MB NVIDIA NVS 510
    Monitor(s) Displays
    ASUS PB278 (2560x1440@59Hz), DELL S2721DS (2560x1440@59Hz), F22 (1920x1080@60Hz), DELL E2311H (1920x1080@60Hz)
    Hard Drives
    931GB Force MP600 primary drive
    931GB Western Digital WDC WD10EALX-759BA1 data drive
    5589GB Seagate Backup+ Hub BK SCSI Disk Device (USB (SATA)) external backup
    Other Info
    See http://speccy.piriform.com/results/a0tsEUMm6hE5R4aEwpTCg3a for full specs
I hadn't checked mine in awhile but doing so required getting a code and entering it then it worked as it should.
 

My Computers

System One System Two

  • OS
    Win11 Pro RTM
    Computer type
    Laptop
    Manufacturer/Model
    Dell Vostro 3400
    CPU
    Intel Core i5 11th Gen. 2.40GHz
    Memory
    12GB
    Hard Drives
    256GB SSD NVMe
  • Operating System
    Windows 11 Pro RTM x64
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Vostro 5890
    CPU
    Intel Core i5 10th Gen. 2.90GHz
    Memory
    16GB
    Graphics card(s)
    Onboard, no VGA, using a DisplayPort-to-VGA adapter
    Monitor(s) Displays
    24" Dell
    Hard Drives
    512GB SSD NVMe, 2TB WDC HDD
    Browser
    Firefox, Edge
    Antivirus
    Windows Defender/Microsoft Security
I hadn't checked mine in awhile but doing so required getting a code and entering it then it worked as it should.
Yeah, any time this has happened to me in the past I had the same thing. No idea why I had such trouble this time, but now I'm locked out and don't know what to do.
 

My Computer

System One

  • OS
    Win11
    CPU
    AMD Ryzen 9 3900X
    Motherboard
    Aorus X570 Elite
    Memory
    96Gb
    Graphics Card(s)
    2047MB NVIDIA NVS 510
    Monitor(s) Displays
    ASUS PB278 (2560x1440@59Hz), DELL S2721DS (2560x1440@59Hz), F22 (1920x1080@60Hz), DELL E2311H (1920x1080@60Hz)
    Hard Drives
    931GB Force MP600 primary drive
    931GB Western Digital WDC WD10EALX-759BA1 data drive
    5589GB Seagate Backup+ Hub BK SCSI Disk Device (USB (SATA)) external backup
    Other Info
    See http://speccy.piriform.com/results/a0tsEUMm6hE5R4aEwpTCg3a for full specs
I got locked out of my outlook.com account by trying the new Outlook then reverting to original. I deleted it and created a new gmail account.
I have 2 gmail accounts I use in Thunderbird.
 

My Computer

System One

  • OS
    Windows 11 Home 23H2 64-Bit
    Computer type
    Laptop
    Manufacturer/Model
    asus f515ja
    CPU
    Intel(R) Core(TM) i5-1035G1 CPU @ 1.00GHz 1.19 GHz
    Motherboard
    ASUSTeK COMPUTER INC. X515JA (U3E1)
    Memory
    8.00GB HDD
    Graphics Card(s)
    Standard Monitor on Intel UHD Graphics
    Sound Card
    Realtek HDA
    Screen Resolution
    1366 x 768 x 60
    Hard Drives
    1HDD 2 Partitions
    Mouse
    Logitech Cordless
    Internet Speed
    38mbps
    Browser
    Chrome+FF
    Antivirus
    Malwarebytes (Premium)
    Other Info
    When I find it.
In the section, where it says “Add email address” you can’t add the original address (so that you have two) and then make that the main alias?

So in “Account Alias” Click Add Email Address” Add your original one which should show as a secondary, change it to the primary so that the new one you created becomes the secondary.

Apologies if you have already tried this and were unsuccessful.
 

My Computers

System One System Two

  • OS
    Windows 11 Pro 23H2 Build: 22631.3593
    Computer type
    PC/Desktop
    Manufacturer/Model
    Sin-built
    CPU
    Intel(R) Core(TM) i7-4770K CPU @ 3.50GHz (4th Gen?)
    Motherboard
    ASUS ROG Maximus VI Formula
    Memory
    32.0 GB of I forget and the box is in storage.
    Graphics Card(s)
    Gigabyte nVidia GeForce GTX 1660 Super OC 6GB
    Sound Card
    Onboard
    Monitor(s) Displays
    4 x LG 23MP75 1 x 24" LG M38H 1 x 32" LF6300 TV Monitor 1 x Wacom Pro 22" Tablet
    Screen Resolution
    All over the place
    Hard Drives
    2 x WD something Something 8TB HDD's / 2 x WD something Something 4TB HDD's / 1 x EVO 1TB SSD / 2 x QVO 1TB SSD's / 1 x EVO 250 GB SSD / 2 x QVO 1TB (External Hub) / 1 x EVO 1TB (Portable Backup Case)
    PSU
    Silverstone 1500
    Case
    NZXT Phantom 820 Full-Tower Case
    Cooling
    Noctua NH-D15 Elite Class Dual Tower CPU Cooler / 6 x EziDIY 120mm / 2 x Corsair 140mm somethings / 1 x 140mm Thermaltake something / 2 x 200mm Corsair.
    Keyboard
    Corsair K95 / Logitech diNovo Edge Wireless
    Mouse
    Logitech G402 / G502 / Mx Masters / MX Air Cordless
    Internet Speed
    100/40Mbps
    Browser
    All sorts
    Antivirus
    Kaspersky Premium
    Other Info
    I’m on a horse.
  • Operating System
    Windows 11 Pro 22621.2215
    Computer type
    Laptop
    Manufacturer/Model
    LENOVO Yoga 7i EVO OLED 14" Touchscreen i5 12 Core 16GB/512GB
    CPU
    Intel Core 12th Gen i5-1240P Processor (1.7 - 4.4GHz)
    Memory
    16GB LPDDR5 RAM
    Graphics card(s)
    Graphics processor is an Intel Iris Xe
    Sound Card
    optimized with Dolby Atmos®
    Screen Resolution
    QHD 2880 x 1800 OLED
    Hard Drives
    M.2 512GB
    Other Info
    …still on a horse.
Have you tried reset password? If you forgot, you can usually change your password to login.
 

My Computers

System One System Two

  • OS
    Windows 11 Pro 24H2
    Computer type
    Laptop
    Manufacturer/Model
    HP ZBook G2
    CPU
    Intel® Core i7 5500u
    Motherboard
    HP
    Memory
    8 GB
    Graphics Card(s)
    Intel HD Family Graphics AMD Firepro 4150M
    Sound Card
    Realtek High Audio
    Hard Drives
    1 TB SSD
    Mouse
    HP USB Mouse
    Antivirus
    Zone Alarm Free Antivirus/Zone Alarm Free Firewall NEXT GEN
  • Operating System
    Windows 11 Pro 24H2
    Computer type
    Laptop
    Manufacturer/Model
    HP Zbook G4
    CPU
    Xeon 1535m v6
    Motherboard
    HP
    Memory
    32 GB
    Graphics card(s)
    AMD Quadro Pro 4100
    Sound Card
    Bang and Olufson Audio
    Hard Drives
    1TB SSD
    Mouse
    HP USB Mouse
    Antivirus
    Zone Alarm Free Antivirus/Zone Alarm Free Firewall NEXT GEN
In the section, where it says “Add email address” you can’t add the original address (so that you have two) and then make that the main alias?
No, it won't let me. Doesn't matter if I try either box, I get the same message...

1709216266173.png

So in “Account Alias” Click Add Email Address” Add your original one which should show as a secondary, change it to the primary so that the new one you created becomes the secondary.

Apologies if you have already tried this and were unsuccessful.

Thanks for the suggestion, but as you can see, I can't add the original email.

Any other ideas?
 

My Computer

System One

  • OS
    Win11
    CPU
    AMD Ryzen 9 3900X
    Motherboard
    Aorus X570 Elite
    Memory
    96Gb
    Graphics Card(s)
    2047MB NVIDIA NVS 510
    Monitor(s) Displays
    ASUS PB278 (2560x1440@59Hz), DELL S2721DS (2560x1440@59Hz), F22 (1920x1080@60Hz), DELL E2311H (1920x1080@60Hz)
    Hard Drives
    931GB Force MP600 primary drive
    931GB Western Digital WDC WD10EALX-759BA1 data drive
    5589GB Seagate Backup+ Hub BK SCSI Disk Device (USB (SATA)) external backup
    Other Info
    See http://speccy.piriform.com/results/a0tsEUMm6hE5R4aEwpTCg3a for full specs
Have you tried reset password? If you forgot, you can usually change your password to login.
Yes, that's where this whole sorry story began. Any attempt to log in, either from Thunderbird or from a browser claimed that my password was wrong (even though I hadn't changed it), and when I tried to change it, outlook insisted on me adding an alias.

I can log in with both the original email and the alias, but either way it shows me a fresh account, not the original
 

My Computer

System One

  • OS
    Win11
    CPU
    AMD Ryzen 9 3900X
    Motherboard
    Aorus X570 Elite
    Memory
    96Gb
    Graphics Card(s)
    2047MB NVIDIA NVS 510
    Monitor(s) Displays
    ASUS PB278 (2560x1440@59Hz), DELL S2721DS (2560x1440@59Hz), F22 (1920x1080@60Hz), DELL E2311H (1920x1080@60Hz)
    Hard Drives
    931GB Force MP600 primary drive
    931GB Western Digital WDC WD10EALX-759BA1 data drive
    5589GB Seagate Backup+ Hub BK SCSI Disk Device (USB (SATA)) external backup
    Other Info
    See http://speccy.piriform.com/results/a0tsEUMm6hE5R4aEwpTCg3a for full specs
No, it won't let me. Doesn't matter if I try either box, I get the same message...

View attachment 88702



Thanks for the suggestion, but as you can see, I can't add the original email.

Any other ideas?
You would need to put it in “add an existing email address” not create a new. Especially that it already exists… that doesn’t work either?
 

My Computers

System One System Two

  • OS
    Windows 11 Pro 23H2 Build: 22631.3593
    Computer type
    PC/Desktop
    Manufacturer/Model
    Sin-built
    CPU
    Intel(R) Core(TM) i7-4770K CPU @ 3.50GHz (4th Gen?)
    Motherboard
    ASUS ROG Maximus VI Formula
    Memory
    32.0 GB of I forget and the box is in storage.
    Graphics Card(s)
    Gigabyte nVidia GeForce GTX 1660 Super OC 6GB
    Sound Card
    Onboard
    Monitor(s) Displays
    4 x LG 23MP75 1 x 24" LG M38H 1 x 32" LF6300 TV Monitor 1 x Wacom Pro 22" Tablet
    Screen Resolution
    All over the place
    Hard Drives
    2 x WD something Something 8TB HDD's / 2 x WD something Something 4TB HDD's / 1 x EVO 1TB SSD / 2 x QVO 1TB SSD's / 1 x EVO 250 GB SSD / 2 x QVO 1TB (External Hub) / 1 x EVO 1TB (Portable Backup Case)
    PSU
    Silverstone 1500
    Case
    NZXT Phantom 820 Full-Tower Case
    Cooling
    Noctua NH-D15 Elite Class Dual Tower CPU Cooler / 6 x EziDIY 120mm / 2 x Corsair 140mm somethings / 1 x 140mm Thermaltake something / 2 x 200mm Corsair.
    Keyboard
    Corsair K95 / Logitech diNovo Edge Wireless
    Mouse
    Logitech G402 / G502 / Mx Masters / MX Air Cordless
    Internet Speed
    100/40Mbps
    Browser
    All sorts
    Antivirus
    Kaspersky Premium
    Other Info
    I’m on a horse.
  • Operating System
    Windows 11 Pro 22621.2215
    Computer type
    Laptop
    Manufacturer/Model
    LENOVO Yoga 7i EVO OLED 14" Touchscreen i5 12 Core 16GB/512GB
    CPU
    Intel Core 12th Gen i5-1240P Processor (1.7 - 4.4GHz)
    Memory
    16GB LPDDR5 RAM
    Graphics card(s)
    Graphics processor is an Intel Iris Xe
    Sound Card
    optimized with Dolby Atmos®
    Screen Resolution
    QHD 2880 x 1800 OLED
    Hard Drives
    M.2 512GB
    Other Info
    …still on a horse.
You would need to put it in “add an existing email address” not create a new. Especially that it already exists… that doesn’t work either?
Nope, tried both, and got the same message...

1709218914870.png

Thanks anyway, any other ideas?
 

My Computer

System One

  • OS
    Win11
    CPU
    AMD Ryzen 9 3900X
    Motherboard
    Aorus X570 Elite
    Memory
    96Gb
    Graphics Card(s)
    2047MB NVIDIA NVS 510
    Monitor(s) Displays
    ASUS PB278 (2560x1440@59Hz), DELL S2721DS (2560x1440@59Hz), F22 (1920x1080@60Hz), DELL E2311H (1920x1080@60Hz)
    Hard Drives
    931GB Force MP600 primary drive
    931GB Western Digital WDC WD10EALX-759BA1 data drive
    5589GB Seagate Backup+ Hub BK SCSI Disk Device (USB (SATA)) external backup
    Other Info
    See http://speccy.piriform.com/results/a0tsEUMm6hE5R4aEwpTCg3a for full specs
Probably Microsoft support.
Or find the email retrieval process. I’m pretty sure there used to be one.
 

My Computers

System One System Two

  • OS
    Windows 11 Pro 23H2 Build: 22631.3593
    Computer type
    PC/Desktop
    Manufacturer/Model
    Sin-built
    CPU
    Intel(R) Core(TM) i7-4770K CPU @ 3.50GHz (4th Gen?)
    Motherboard
    ASUS ROG Maximus VI Formula
    Memory
    32.0 GB of I forget and the box is in storage.
    Graphics Card(s)
    Gigabyte nVidia GeForce GTX 1660 Super OC 6GB
    Sound Card
    Onboard
    Monitor(s) Displays
    4 x LG 23MP75 1 x 24" LG M38H 1 x 32" LF6300 TV Monitor 1 x Wacom Pro 22" Tablet
    Screen Resolution
    All over the place
    Hard Drives
    2 x WD something Something 8TB HDD's / 2 x WD something Something 4TB HDD's / 1 x EVO 1TB SSD / 2 x QVO 1TB SSD's / 1 x EVO 250 GB SSD / 2 x QVO 1TB (External Hub) / 1 x EVO 1TB (Portable Backup Case)
    PSU
    Silverstone 1500
    Case
    NZXT Phantom 820 Full-Tower Case
    Cooling
    Noctua NH-D15 Elite Class Dual Tower CPU Cooler / 6 x EziDIY 120mm / 2 x Corsair 140mm somethings / 1 x 140mm Thermaltake something / 2 x 200mm Corsair.
    Keyboard
    Corsair K95 / Logitech diNovo Edge Wireless
    Mouse
    Logitech G402 / G502 / Mx Masters / MX Air Cordless
    Internet Speed
    100/40Mbps
    Browser
    All sorts
    Antivirus
    Kaspersky Premium
    Other Info
    I’m on a horse.
  • Operating System
    Windows 11 Pro 22621.2215
    Computer type
    Laptop
    Manufacturer/Model
    LENOVO Yoga 7i EVO OLED 14" Touchscreen i5 12 Core 16GB/512GB
    CPU
    Intel Core 12th Gen i5-1240P Processor (1.7 - 4.4GHz)
    Memory
    16GB LPDDR5 RAM
    Graphics card(s)
    Graphics processor is an Intel Iris Xe
    Sound Card
    optimized with Dolby Atmos®
    Screen Resolution
    QHD 2880 x 1800 OLED
    Hard Drives
    M.2 512GB
    Other Info
    …still on a horse.
Probably Microsoft support.
Ha ha ha ha 😁😆😅🤣😂

Oh dear, you shouldn't do that to me without warning! Fancy suggesting that Microsoft would support something as minor as being completely locked out of your account.

I did try and get some support, but never found a way to get any.

Or find the email retrieval process. I’m pretty sure there used to be one.
I have looked around for things like this, but only found articles about not being able to sign in (which isn't strictly true as I can sign in, just can't see the primary account) or how to recover a hacked account.

However, I did just find an account recovery form, so will see if that gets me anywhere.

Thanks again
 

My Computer

System One

  • OS
    Win11
    CPU
    AMD Ryzen 9 3900X
    Motherboard
    Aorus X570 Elite
    Memory
    96Gb
    Graphics Card(s)
    2047MB NVIDIA NVS 510
    Monitor(s) Displays
    ASUS PB278 (2560x1440@59Hz), DELL S2721DS (2560x1440@59Hz), F22 (1920x1080@60Hz), DELL E2311H (1920x1080@60Hz)
    Hard Drives
    931GB Force MP600 primary drive
    931GB Western Digital WDC WD10EALX-759BA1 data drive
    5589GB Seagate Backup+ Hub BK SCSI Disk Device (USB (SATA)) external backup
    Other Info
    See http://speccy.piriform.com/results/a0tsEUMm6hE5R4aEwpTCg3a for full specs

My Computers

System One System Two

  • OS
    Windows 11 Pro 23H2 Build: 22631.3593
    Computer type
    PC/Desktop
    Manufacturer/Model
    Sin-built
    CPU
    Intel(R) Core(TM) i7-4770K CPU @ 3.50GHz (4th Gen?)
    Motherboard
    ASUS ROG Maximus VI Formula
    Memory
    32.0 GB of I forget and the box is in storage.
    Graphics Card(s)
    Gigabyte nVidia GeForce GTX 1660 Super OC 6GB
    Sound Card
    Onboard
    Monitor(s) Displays
    4 x LG 23MP75 1 x 24" LG M38H 1 x 32" LF6300 TV Monitor 1 x Wacom Pro 22" Tablet
    Screen Resolution
    All over the place
    Hard Drives
    2 x WD something Something 8TB HDD's / 2 x WD something Something 4TB HDD's / 1 x EVO 1TB SSD / 2 x QVO 1TB SSD's / 1 x EVO 250 GB SSD / 2 x QVO 1TB (External Hub) / 1 x EVO 1TB (Portable Backup Case)
    PSU
    Silverstone 1500
    Case
    NZXT Phantom 820 Full-Tower Case
    Cooling
    Noctua NH-D15 Elite Class Dual Tower CPU Cooler / 6 x EziDIY 120mm / 2 x Corsair 140mm somethings / 1 x 140mm Thermaltake something / 2 x 200mm Corsair.
    Keyboard
    Corsair K95 / Logitech diNovo Edge Wireless
    Mouse
    Logitech G402 / G502 / Mx Masters / MX Air Cordless
    Internet Speed
    100/40Mbps
    Browser
    All sorts
    Antivirus
    Kaspersky Premium
    Other Info
    I’m on a horse.
  • Operating System
    Windows 11 Pro 22621.2215
    Computer type
    Laptop
    Manufacturer/Model
    LENOVO Yoga 7i EVO OLED 14" Touchscreen i5 12 Core 16GB/512GB
    CPU
    Intel Core 12th Gen i5-1240P Processor (1.7 - 4.4GHz)
    Memory
    16GB LPDDR5 RAM
    Graphics card(s)
    Graphics processor is an Intel Iris Xe
    Sound Card
    optimized with Dolby Atmos®
    Screen Resolution
    QHD 2880 x 1800 OLED
    Hard Drives
    M.2 512GB
    Other Info
    …still on a horse.
I did try and get some support, but never found a way to get any.
Buy MS 365 Basic for a month, it is worth $2, but you will get an excellent support.
I had a problem and we spent an hour trying to figure it out, it was caused by "space".

However, I did just find an account recovery form, so will see if that gets me anywhere.
That depends what recovery methods you have. You should have a recovery code, optionally: PIN, SMS, emails, authenticator.
 

Attachments

  • capture_02292024_170857.jpg
    capture_02292024_170857.jpg
    24.6 KB · Views: 1
  • capture_02292024_170952.jpg
    capture_02292024_170952.jpg
    30.6 KB · Views: 1

My Computer

System One

  • OS
    Windows 11 Home
    Computer type
    PC/Desktop
    CPU
    AMD Ryzen 5 3600 & No fTPM (07/19)
    Motherboard
    MSI B450 TOMAHAWK 7C02v1E & IFX TPM (07/19)
    Memory
    4x 8GB ADATA XPG GAMMIX D10 DDR4 3200MHz CL16
    Graphics Card(s)
    MSI Radeon RX 580 ARMOR 8G OC @48FPS (08/19)
    Sound Card
    Creative Sound Blaster Z (11/16)
    Monitor(s) Displays
    24" Philips 24M1N3200ZS/00 (05/24)
    Screen Resolution
    1920×1080@165Hz via DP1.4
    Hard Drives
    ADATA XPG GAMMIX S11 Pro SSD 512GB (07/19)
    PSU
    Seasonic M12II-520 80 Plus Bronze (11/16)
    Case
    Lian Li PC-7NB & 3x Noctua NF-S12A FLX@700rpm (11/16)
    Cooling
    CPU Cooler Noctua NH-U12S@700rpm (07/19)
    Keyboard
    HP Wired Desktop 320K + Rabalux 76017 Parker (01/24)
    Mouse
    Logitech M330 Silent Plus (04/23)
    Internet Speed
    400/40 Mbps via RouterOS (05/21) & TCP Optimizer
    Browser
    Edge & Brave for YouTube & LibreWolf for FB
    Antivirus
    NoAV & Binisoft WFC & NextDNS
    Other Info
    Backup: Hasleo Backup Suite (PreOS)
    Notifier: Xiaomi Mi Band 7 NFC (05/24)
    Headphones: Sennheiser RS170 (09/10)
    Phone: Samsung Galaxy Xcover 7 (02/24)
    2nd Monitor: AOC G2460VQ6 @75Hz (02/19)

My Computer

System One

  • OS
    Win11
    CPU
    AMD Ryzen 9 3900X
    Motherboard
    Aorus X570 Elite
    Memory
    96Gb
    Graphics Card(s)
    2047MB NVIDIA NVS 510
    Monitor(s) Displays
    ASUS PB278 (2560x1440@59Hz), DELL S2721DS (2560x1440@59Hz), F22 (1920x1080@60Hz), DELL E2311H (1920x1080@60Hz)
    Hard Drives
    931GB Force MP600 primary drive
    931GB Western Digital WDC WD10EALX-759BA1 data drive
    5589GB Seagate Backup+ Hub BK SCSI Disk Device (USB (SATA)) external backup
    Other Info
    See http://speccy.piriform.com/results/a0tsEUMm6hE5R4aEwpTCg3a for full specs
Buy MS 365 Basic for a month, it is worth $2, but you will get an excellent support.
I had a problem and we spent an hour trying to figure it out, it was caused by "space".
Hmm, that's a clever idea, will look into it.

That depends what recovery methods you have. You should have a recovery code, optionally: PIN, SMS, emails, authenticator.
I tried the form, but they rejected my request saying I hadn't supplied enough info. Trouble was, the only info they asked for that would identify the account was the addresses and subject lines of some recent sent emails. However, I haven't used this account for sending emails for quite a few years. I only use it for incoming emails, so couldn't give them the info.

Maybe I'll see if MS365 gives any support.

Thanks again
 

My Computer

System One

  • OS
    Win11
    CPU
    AMD Ryzen 9 3900X
    Motherboard
    Aorus X570 Elite
    Memory
    96Gb
    Graphics Card(s)
    2047MB NVIDIA NVS 510
    Monitor(s) Displays
    ASUS PB278 (2560x1440@59Hz), DELL S2721DS (2560x1440@59Hz), F22 (1920x1080@60Hz), DELL E2311H (1920x1080@60Hz)
    Hard Drives
    931GB Force MP600 primary drive
    931GB Western Digital WDC WD10EALX-759BA1 data drive
    5589GB Seagate Backup+ Hub BK SCSI Disk Device (USB (SATA)) external backup
    Other Info
    See http://speccy.piriform.com/results/a0tsEUMm6hE5R4aEwpTCg3a for full specs

Latest Support Threads

Back
Top Bottom