Solved New PC. Microsoft Account user w/ two-step verify. Device not Trusted. Repeat verify


chockfullof546

Active member
Local time
10:07 PM
Posts
27
OS
windows 11 pro 23H2
Just got a new Windows 11desktop pc. Came with local renamed no password administrator account. Everything works? Check! My Microsoft online account has two-step verification using phone text turned on. My 6 year old computer Windows 10 pc I never have to verify except when I change the password.

On new pc I setup another Admin account Microsoft user based. I logged in a text verified. Check. However now every new time I login to the Microsoft admin account I have to text verify. Un-check. Cannot figure out why.

Microsoft help says while verifying the login I'm supposed to see a check box to Trust this pc, but I never see it. Logging online to my Microsoft Account I can see both devices listed. I can see how to turn two-step ON/OFF, but that seems to be for the account as a whole. Don't see anything about Trust. Cannot remember what I did to older pc to make it Trusted.

Can anybody tell me how to not endlessly have to verify the new pc? Thanks for any help in advance?
 

My Computer

System One

  • OS
    windows 11 pro 23H2
    Computer type
    PC/Desktop
    Manufacturer/Model
    OriginPC
    CPU
    AMD Ryzen 7 5800X
    Motherboard
    ASUS ROG STRIX B550-I Gaming
    Memory
    Corsair
    Graphics Card(s)
    Nvidia RTX 3060 Ti
    Monitor(s) Displays
    LG TV
    Screen Resolution
    4K
    Hard Drives
    Samsung 980 Pro
    Seagate Iron Wolf Pro
    PSU
    700w
    Case
    Custom
    Keyboard
    USB
    Mouse
    KB trackpad
    Internet Speed
    GBit fiber

My Computers

System One System Two

  • OS
    Windows 11 Pro 23H2 22631.3447
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 7080
    CPU
    i9-10900 10 core 20 threads
    Motherboard
    DELL 0J37VM
    Memory
    32 gb
    Graphics Card(s)
    none-Intel UHD Graphics 630
    Sound Card
    Integrated Realtek
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    1tb Solidigm m.2 +256gb ssd+512 gb usb m.2 sata
    PSU
    500w
    Case
    MT
    Cooling
    Dell Premium
    Keyboard
    Logitech wired
    Mouse
    Logitech wireless
    Internet Speed
    so slow I'm too embarrassed to tell
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
  • Operating System
    Windows 10 Pro 22H2 19045.3930
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 9020
    CPU
    i7-4770
    Memory
    24 gb
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    256 gb Toshiba BG4 M.2 NVE SSB and 1 tb hdd
    PSU
    500w
    Case
    MT
    Cooling
    Dell factory
    Mouse
    Logitech wireless
    Keyboard
    Logitech wired
    Internet Speed
    still not telling
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
Thanks for posting so quickly. When it's solved I will be sure to post that. I'm not sure how to report solved. Do I click on the "REPORT" link in the lower left of your post?

Yes, I saw that help before and tried to follow it. As mentioned there was no Don't ask me again on this device checkbox. However, this time it didn't repeat text verification. But that only works for my internet Microsoft account. When I restarted my pc I again was required to repeat text verification logging into my pc. Perhaps I'm not explaining this well, but some setting, somewhere make logging into my pc account on the computer itself repeat text verification.

When logged into my online Microsoft account and go to the security tab I can see all my pc's and activity.
 

My Computer

System One

  • OS
    windows 11 pro 23H2
    Computer type
    PC/Desktop
    Manufacturer/Model
    OriginPC
    CPU
    AMD Ryzen 7 5800X
    Motherboard
    ASUS ROG STRIX B550-I Gaming
    Memory
    Corsair
    Graphics Card(s)
    Nvidia RTX 3060 Ti
    Monitor(s) Displays
    LG TV
    Screen Resolution
    4K
    Hard Drives
    Samsung 980 Pro
    Seagate Iron Wolf Pro
    PSU
    700w
    Case
    Custom
    Keyboard
    USB
    Mouse
    KB trackpad
    Internet Speed
    GBit fiber
At the top of your thread, right under its title, there is a button to click when solved. By the way, it's good to have to on the forum.

This tutorial was written for Windows 10 but the process should be quite similar. See if there is anything in it that might help.
 

My Computers

System One System Two

  • OS
    Windows 11 Pro 23H2 22631.3447
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 7080
    CPU
    i9-10900 10 core 20 threads
    Motherboard
    DELL 0J37VM
    Memory
    32 gb
    Graphics Card(s)
    none-Intel UHD Graphics 630
    Sound Card
    Integrated Realtek
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    1tb Solidigm m.2 +256gb ssd+512 gb usb m.2 sata
    PSU
    500w
    Case
    MT
    Cooling
    Dell Premium
    Keyboard
    Logitech wired
    Mouse
    Logitech wireless
    Internet Speed
    so slow I'm too embarrassed to tell
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
  • Operating System
    Windows 10 Pro 22H2 19045.3930
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 9020
    CPU
    i7-4770
    Memory
    24 gb
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    256 gb Toshiba BG4 M.2 NVE SSB and 1 tb hdd
    PSU
    500w
    Case
    MT
    Cooling
    Dell factory
    Mouse
    Logitech wireless
    Keyboard
    Logitech wired
    Internet Speed
    still not telling
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
Just got a new Windows 11desktop pc. Came with local renamed no password administrator account.
So your PC came with preinstalled Windows 11? Windows 11 requires MS account, if it has a local only, the shop has most likely bypassed it and it might have setup something preventing you from staying logged in. It is not safe to use preinstall OS either away.

You should clean install Windows yourself or at least perform a repair upgrade to fix possible "tweaks".

 

My Computer

System One

  • OS
    Windows 11 Home
    Computer type
    PC/Desktop
    CPU
    AMD Ryzen 5 3600 & No fTPM (07/19)
    Motherboard
    MSI B450 TOMAHAWK 7C02v1E & IFX TPM (07/19)
    Memory
    4x 8GB ADATA XPG GAMMIX D10 DDR4 3200MHz CL16
    Graphics Card(s)
    MSI Radeon RX 580 ARMOR 8G OC @48FPS (08/19)
    Sound Card
    Creative Sound Blaster Z (11/16)
    Monitor(s) Displays
    24" AOC G2460VQ6 (01/19)
    Screen Resolution
    1920×1080@75Hz & FreeSync (DisplayPort)
    Hard Drives
    ADATA XPG GAMMIX S11 Pro SSD 512GB (07/19)
    PSU
    Seasonic M12II-520 80 Plus Bronze (11/16)
    Case
    Lian Li PC-7NB & 3x Noctua NF-S12A FLX@700rpm (11/16)
    Cooling
    CPU Cooler Noctua NH-U12S@700rpm (07/19)
    Keyboard
    HP Wired Desktop 320K + Rabalux 76017 Parker (01/24)
    Mouse
    Logitech M330 Silent Plus (04/23)
    Internet Speed
    400/40 Mbps via RouterOS (05/21) & TCP Optimizer
    Browser
    Edge (No FB/Google) & Brave for YouTube & LibreWolf for FB
    Antivirus
    NoAV & Binisoft WFC & NextDNS
    Other Info
    Headphones: Sennheiser RS170 (09/10)
    Phone: Samsung Galaxy Xcover 7 (02/24)
That the PC came with a user account already created does indicate that the PC is used or setup by someone else.
@TairikuOkami idea is a good one as far as clean install. A reset and remove everything might also work. I don't think a repair install would fix it though as a repair install will not alter user accounts or the registry entries pertaining to them.
 

My Computers

System One System Two

  • OS
    Windows 11 Pro 23H2 22631.3447
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 7080
    CPU
    i9-10900 10 core 20 threads
    Motherboard
    DELL 0J37VM
    Memory
    32 gb
    Graphics Card(s)
    none-Intel UHD Graphics 630
    Sound Card
    Integrated Realtek
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    1tb Solidigm m.2 +256gb ssd+512 gb usb m.2 sata
    PSU
    500w
    Case
    MT
    Cooling
    Dell Premium
    Keyboard
    Logitech wired
    Mouse
    Logitech wireless
    Internet Speed
    so slow I'm too embarrassed to tell
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
  • Operating System
    Windows 10 Pro 22H2 19045.3930
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 9020
    CPU
    i7-4770
    Memory
    24 gb
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    256 gb Toshiba BG4 M.2 NVE SSB and 1 tb hdd
    PSU
    500w
    Case
    MT
    Cooling
    Dell factory
    Mouse
    Logitech wireless
    Keyboard
    Logitech wired
    Internet Speed
    still not telling
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
Thanks everybody for your ideas. I'd prefer to try other solution besides doing some kind of install.

If everybody will bear with me first I'd appreciate additional suggestions before an install. Let me fill in additional details that might clarify my setup. I bought the semi-custom pc from ORIGIN PC, now a Corsair subsidiary, last month. My older pc was a ORIGIN that was very satisfactory. I didn't want any internal hardware lighting, Corsair iCue, but was told it could be turned off in its software. ORIGIN built, tested and delivered the pc with a fresh copy of Windows that I began with the normal setup screens.

The pc was working, almost, great except for the lighting. All the HW was lit up, but not all components showed in iCue. After trying myself I called their support, which solved any few issues on the old pc that came up for 6 years, then they remoted in to attempt to fix the lighting. After reconnecting all the cables the HDMI video died. Shipped pc back for repair, their dime both ways, and it came back 2 days ago with a Windows fully installed and a local user account setup as already described, I created another admin microsoft account user going through that wizard and was now in verify loop. Support remoted in. Looked at my settings for 5-10 minutes then gave up and told me to contact Microsoft.
 

My Computer

System One

  • OS
    windows 11 pro 23H2
    Computer type
    PC/Desktop
    Manufacturer/Model
    OriginPC
    CPU
    AMD Ryzen 7 5800X
    Motherboard
    ASUS ROG STRIX B550-I Gaming
    Memory
    Corsair
    Graphics Card(s)
    Nvidia RTX 3060 Ti
    Monitor(s) Displays
    LG TV
    Screen Resolution
    4K
    Hard Drives
    Samsung 980 Pro
    Seagate Iron Wolf Pro
    PSU
    700w
    Case
    Custom
    Keyboard
    USB
    Mouse
    KB trackpad
    Internet Speed
    GBit fiber
Thanks everybody for your ideas. I'd prefer to try other solution besides doing some kind of install.

If everybody will bear with me first I'd appreciate additional suggestions before an install. Let me fill in additional details that might clarify my setup. I bought the semi-custom pc from ORIGIN PC, now a Corsair subsidiary, last month. My older pc was a ORIGIN that was very satisfactory. I didn't want any internal hardware lighting, Corsair iCue, but was told it could be turned off in its software. ORIGIN built, tested and delivered the pc with a fresh copy of Windows that I began with the normal setup screens.

The pc was working, almost, great except for the lighting. All the HW was lit up, but not all components showed in iCue. After trying myself I called their support, which solved any few issues on the old pc that came up for 6 years, then they remoted in to attempt to fix the lighting. After reconnecting all the cables the HDMI video died. Shipped pc back for repair, their dime both ways, and it came back 2 days ago with a Windows fully installed and a local user account setup as already described, I created another admin microsoft account user going through that wizard and was now in verify loop. Support remoted in. Looked at my settings for 5-10 minutes then gave up and told me to contact Microsoft.
If you haven't installed any programs or made any changes, I recommend doing a clean install. They should have left it, so you had to set it up from scratch. IMHO it will save a few headaches. If you do decide to clean install, backup the drivers first. I think there is a tutorial how to do it on this forum.
Edit: I found the tutorial on Tenforums. Backup and Restore Device Drivers in Windows 10
 
Last edited:

My Computers

System One System Two

  • OS
    Windows 11 Canary Channel
    Computer type
    PC/Desktop
    Manufacturer/Model
    PowerSpec B746
    CPU
    Intel Core i7-10700K
    Motherboard
    ASRock Z490 Phantom Gaming 4/ax
    Memory
    16GB (8GB PC4-19200 DDR4 SDRAM x2)
    Graphics Card(s)
    NVIDIA GeForce GTX 1050 TI
    Sound Card
    Realtek Audio
    Monitor(s) Displays
    Samsung SAM0A87 Samsung SAM0D32
    Screen Resolution
    1920 x 1080
    Hard Drives
    NVMe WDC WDS100T2B0C-00PXH0 1TB
    Samsung SSD 860 EVO 1TB
    PSU
    750 Watts (62.5A)
    Case
    PowerSpec/Lian Li ATX 205
    Keyboard
    Logitech K270
    Mouse
    Logitech M185
    Browser
    Microsoft Edge and Firefox
    Antivirus
    ESET Internet Security
  • Operating System
    Windows 11 Canary Channel
    Computer type
    PC/Desktop
    Manufacturer/Model
    PowerSpec G156
    CPU
    Intel Core i5-8400 CPU @ 2.80GHz
    Motherboard
    AsusTeK Prime B360M-S
    Memory
    16 MB DDR 4-2666
    Monitor(s) Displays
    23" Speptre HDMI 75Hz
    Screen Resolution
    1920x1080
    Hard Drives
    Samsung 970 EVO 500GB NVMe
    Mouse
    Logitek M185
    Keyboard
    Logitek K270
    Browser
    Firefox, Edge and Edge Canary
    Antivirus
    Windows Defender
Taking everybody's advice, checking my pc and Microsoft Account settings I could only tell this pc was a trusted advice Also, even if I reinstall I fear I'll choose the same account choices that will leave me in the same predicament. So I'd like to describe some that might be relevant. If I remember,

I skipped a PIN and Windows Hello. In Settings / Privacy+Security it says I should turn on Hello, but I don't want a PIN. Yes this alone is an endless argument.

I did not set anything, to sync between my computers except my OneDrive account. Accounts / Your Info says syncing works better. Of course they would, but I do not want Microsoft storing that in the cloud.

I've had a Microsoft account using a live.com e-mail address. Under E-Mail and Accounts it shows my Microsoft e-mail with Live below it. Under Accounts used by other apps/accounts it shows the e-mail address, but Microsoft icon and Microsoft account below that.

Setting up Edge I turned off everything I could find that would save or share data.

I now have verified loop and the tech I got both times at ORIGIN PC tells me software problems belong to Microsoft not him.

I am worried about reinstall or repair will hinder getting any vendor support. I slo haven't done that in years. Their is a EFI 1st partition, Boot NTFS C: partition and third NTFS Recovery partition. I do not want to mess those up with an install unless it's my only option.


Any further suggestions are welcome.
 

My Computer

System One

  • OS
    windows 11 pro 23H2
    Computer type
    PC/Desktop
    Manufacturer/Model
    OriginPC
    CPU
    AMD Ryzen 7 5800X
    Motherboard
    ASUS ROG STRIX B550-I Gaming
    Memory
    Corsair
    Graphics Card(s)
    Nvidia RTX 3060 Ti
    Monitor(s) Displays
    LG TV
    Screen Resolution
    4K
    Hard Drives
    Samsung 980 Pro
    Seagate Iron Wolf Pro
    PSU
    700w
    Case
    Custom
    Keyboard
    USB
    Mouse
    KB trackpad
    Internet Speed
    GBit fiber
You can always reset and use remove everything option providing they gave you a recovery partition..
 

My Computers

System One System Two

  • OS
    Windows 11 Pro 23H2 22631.3447
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 7080
    CPU
    i9-10900 10 core 20 threads
    Motherboard
    DELL 0J37VM
    Memory
    32 gb
    Graphics Card(s)
    none-Intel UHD Graphics 630
    Sound Card
    Integrated Realtek
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    1tb Solidigm m.2 +256gb ssd+512 gb usb m.2 sata
    PSU
    500w
    Case
    MT
    Cooling
    Dell Premium
    Keyboard
    Logitech wired
    Mouse
    Logitech wireless
    Internet Speed
    so slow I'm too embarrassed to tell
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
  • Operating System
    Windows 10 Pro 22H2 19045.3930
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 9020
    CPU
    i7-4770
    Memory
    24 gb
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    256 gb Toshiba BG4 M.2 NVE SSB and 1 tb hdd
    PSU
    500w
    Case
    MT
    Cooling
    Dell factory
    Mouse
    Logitech wireless
    Keyboard
    Logitech wired
    Internet Speed
    still not telling
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
Called ORIGIN PC. They agreed with your install fresh copy of Windows and are e-mailing me a guide. Perhaps I remember your forum also has a tutorial I can follow.

They told me I don't have to worry about the BIOS, but all 3 partitions get deleted. Correct?

I'm still worried the problem is the choices I made during User Setup wizard, Any recommendations for changes to my choices would be greatly appreciated. However, I really prefer not sharing settings between my other pc especially concerning Edge.
 

My Computer

System One

  • OS
    windows 11 pro 23H2
    Computer type
    PC/Desktop
    Manufacturer/Model
    OriginPC
    CPU
    AMD Ryzen 7 5800X
    Motherboard
    ASUS ROG STRIX B550-I Gaming
    Memory
    Corsair
    Graphics Card(s)
    Nvidia RTX 3060 Ti
    Monitor(s) Displays
    LG TV
    Screen Resolution
    4K
    Hard Drives
    Samsung 980 Pro
    Seagate Iron Wolf Pro
    PSU
    700w
    Case
    Custom
    Keyboard
    USB
    Mouse
    KB trackpad
    Internet Speed
    GBit fiber

You want to make sure at step 11 that all partitions are deleted and windows is installed on unallocated space.
Be aware that any software Origin installed will have to be reinstalled. Any light settings will be lost.
 

My Computers

System One System Two

  • OS
    Windows 11 Pro 23H2 22631.3447
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 7080
    CPU
    i9-10900 10 core 20 threads
    Motherboard
    DELL 0J37VM
    Memory
    32 gb
    Graphics Card(s)
    none-Intel UHD Graphics 630
    Sound Card
    Integrated Realtek
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    1tb Solidigm m.2 +256gb ssd+512 gb usb m.2 sata
    PSU
    500w
    Case
    MT
    Cooling
    Dell Premium
    Keyboard
    Logitech wired
    Mouse
    Logitech wireless
    Internet Speed
    so slow I'm too embarrassed to tell
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
  • Operating System
    Windows 10 Pro 22H2 19045.3930
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 9020
    CPU
    i7-4770
    Memory
    24 gb
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    256 gb Toshiba BG4 M.2 NVE SSB and 1 tb hdd
    PSU
    500w
    Case
    MT
    Cooling
    Dell factory
    Mouse
    Logitech wireless
    Keyboard
    Logitech wired
    Internet Speed
    still not telling
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
Yes, thanks for the tips.

Vendor made me an iCue profile to black out lights. I'll try to save it and just hope it's lights out and that I don't need to do anything installing iCue.

Can I leave this post open until after fresh install and verification loop is no more?
 

My Computer

System One

  • OS
    windows 11 pro 23H2
    Computer type
    PC/Desktop
    Manufacturer/Model
    OriginPC
    CPU
    AMD Ryzen 7 5800X
    Motherboard
    ASUS ROG STRIX B550-I Gaming
    Memory
    Corsair
    Graphics Card(s)
    Nvidia RTX 3060 Ti
    Monitor(s) Displays
    LG TV
    Screen Resolution
    4K
    Hard Drives
    Samsung 980 Pro
    Seagate Iron Wolf Pro
    PSU
    700w
    Case
    Custom
    Keyboard
    USB
    Mouse
    KB trackpad
    Internet Speed
    GBit fiber
of course
 

My Computers

System One System Two

  • OS
    Windows 11 Pro 23H2 22631.3447
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 7080
    CPU
    i9-10900 10 core 20 threads
    Motherboard
    DELL 0J37VM
    Memory
    32 gb
    Graphics Card(s)
    none-Intel UHD Graphics 630
    Sound Card
    Integrated Realtek
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    1tb Solidigm m.2 +256gb ssd+512 gb usb m.2 sata
    PSU
    500w
    Case
    MT
    Cooling
    Dell Premium
    Keyboard
    Logitech wired
    Mouse
    Logitech wireless
    Internet Speed
    so slow I'm too embarrassed to tell
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
  • Operating System
    Windows 10 Pro 22H2 19045.3930
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 9020
    CPU
    i7-4770
    Memory
    24 gb
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    256 gb Toshiba BG4 M.2 NVE SSB and 1 tb hdd
    PSU
    500w
    Case
    MT
    Cooling
    Dell factory
    Mouse
    Logitech wireless
    Keyboard
    Logitech wired
    Internet Speed
    still not telling
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
Solved by creating a PIN allowed password login w/o verify text loop.

PS: I also, allowed non-HELLO sign in option.
 

My Computer

System One

  • OS
    windows 11 pro 23H2
    Computer type
    PC/Desktop
    Manufacturer/Model
    OriginPC
    CPU
    AMD Ryzen 7 5800X
    Motherboard
    ASUS ROG STRIX B550-I Gaming
    Memory
    Corsair
    Graphics Card(s)
    Nvidia RTX 3060 Ti
    Monitor(s) Displays
    LG TV
    Screen Resolution
    4K
    Hard Drives
    Samsung 980 Pro
    Seagate Iron Wolf Pro
    PSU
    700w
    Case
    Custom
    Keyboard
    USB
    Mouse
    KB trackpad
    Internet Speed
    GBit fiber
Back
Top Bottom