PIN sign-in bugged in Windows 11 domain


ditendra08

New member
Local time
4:39 PM
Posts
2
OS
Windows11
Hello everyone,
apparently I'm having a very rare bug in Windows 11 regarding PIN sign-in... My work computer is in domain and as we know by default PIN sign-in in domain is disabled, however it can be enabled via group policy. I have enabled it via group policy, set the PIN, but seems like PIN complexity in group policy is bugged in Windows 11 in domain, because I also changed it to minimum 4 characters, yet Windows is telling me that I need to have 6 characters and it won't let me change to 4. So, then I decided to add picture sign-in. I did it easily, however, when Windows starts by default it still asks me PIN to enter, not the picture sign in. So, I tried to remove this PIN sign-in at all, but seems like it's grayed out. I googled it and articles say to turn Off the toggle switch next to “For improved security, only allow Windows Hello sign-in for Microsoft accounts on this device“ in Accounts -> Sign-in option. However I don't even have “For improved security, only allow Windows Hello sign-in for Microsoft accounts on this device“ there at all! Apparently disabling PIN sign-in via group policy isn't working either. Another solution I found is to disable PIN via regedit, I did that too, which grayed out everything about PIN in settings and said PIN unavalable, but when starting Windows I still have this plagued PIN sign in, sigh... It feels like PIN sign-in is forced so strongly that nothing seems to be working to get rid off it or at least change it to 4 characters instead of 6. I don't know what else to do, I'm going crazy. I can't get rid off PIN at all.

Note that this problem is occurring only in domain. If I join workgroup with local user, everything is working fine, for example I can set PIN with only 4 characters and if picture signin is enabled too, Windows asks me to use the method which was last used. Everything seems perfect, but as soon as I join back to domain, all those nightmare is happening what I described earlier.
 

My Computer

System One

  • OS
    Windows11
Did you also change the requirements for the passcode? You need to make sure that both are compatible.
 

My Computer

System One

  • OS
    Linux Arch (Windows 11 in a VM)
Did you also change the requirements for the passcode? You need to make sure that both are compatible.
I did of course. Anyway, I found a fix for this solution. Seems like instead of going to "Computer Configuration -> Administrative Templates -> System -> Logon -> Turn on Convenience PIN sign-in", I had to go to "Computer Configuration -> Administrative Templates -> Windows Components -> Windows Hello for Business". Since, I enabled it, everything worked fine.
 

My Computer

System One

  • OS
    Windows11
Back
Top Bottom